raspberry pi 3 b+をゲットしたので、久しぶりにraspbianをインストールします。
(Amazonのタイムセールで衝動的に購入してしまいました...)
## 内容
* Raspberry Pi 3 Model B+
* ケース
* SDカード (32G)
* ACアダプタ
* SDカードリーダー
* ヒートシンク
* HDMIケーブル
キーボードとマウスを用意すれば、使い始めることができそうです。
### 環境とraspbianインストールの流れ.
* MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
* macOS 10.14.4
1. イメージのDL
2. イメージをSDカードに焼く
3. 起動
### イメージをDL
[本家のサイト](https://www.raspberrypi.org/downloads/raspbian/)だと1時間とかかかるので、以下のミラーサイトからDLしました。
* [JAISTのミラーサイト](http://ftp.jaist.ac.jp/pub/raspberrypi/raspbian/images/)
### イメージをSDカードに焼く
ddコマンドで焼きます。
焼きかたはいつも公式サイトのコマンドを叩くだけ...
```bash
`gutter:false;
sudo dd bs=1m if=path_of_your_image.img of=/dev/rdiskn conv=sync
```
1. SDカードをMacに接続
2. diskutil listでsdカードのdisk番号を調べる(今回は2)
3. diskutil unmountDisk /dev/disk2 でsdカードをアンマウント
4. ddコマンドで書き込む
```bash
`gutter:false;
$ diskutil list
/dev/disk0 (internal):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme 500.3 GB disk0
1: EFI EFI 314.6 MB disk0s1
2: Apple_APFS Container disk1 500.0 GB disk0s2
/dev/disk1 (synthesized):
#: TYPE NAME SIZE IDENTIFIER
0: APFS Container Scheme - +500.0 GB disk1
Physical Store disk0s2
1: APFS Volume Macintosh HD 311.6 GB disk1s1
2: APFS Volume Preboot 66.4 MB disk1s2
3: APFS Volume Recovery 1.0 GB disk1s3
4: APFS Volume VM 3.2 GB disk1s4
/dev/disk2 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *31.9 GB disk2
1: Windows_FAT_32 NO NAME 31.9 GB disk2s1
$ diskutil unmountDisk /dev/disk2
Unmount of all volumes on disk2 was successful
$ sudo dd bs=1m if=/Users/kazuya/Downloads/2019-04-08-raspbian-stretch.img of=/dev/rdisk2 conv=sync
Password:
3320+0 records in
3320+0 records out
3481272320 bytes transferred in 222.630021 secs (15637030 bytes/sec)
$
```
WiFiがついていたり、処理速度などが向上しているみたいなので、色々遊べそうです。
(今年 Raspberry Piでやってみたい事ができるはず 簡易WiFi作ってみるとか)
## 参考URL
* [公式サイト](https://www.raspberrypi.org/documentation/installation/installing-images/mac.md)
* [Raspberry Piのイメージをミラーからダウンロードする](https://www.zinntikumugai.com/2017/09/17/-3492-/)
0 件のコメント :
コメントを投稿